Librecad Documentation Download

Copy and paste this link to your website, so they can see this document directly without any plugins.



Keywords

have, that, this, part, using, little, will, LibreCAD, layer, create, point, Drawing, then, mechanical, Page, CLAUDIO, GUARNIERI:, axes, click, with, select, here, from, first, just, down, line, units, about, look

Transcript

TUTORIAL
Drawing a little mechanical
part using LibreCAD
Tutorial by Claudio Guarnieri
CLAUDIO GUARNIERI: Drawing a little mechanical part using LibreCAD – Page 1 of 17
Introduction
Hello everyone! This tutorial is a tutorial for beginners and is made mainly for people
that are not into LibreCAD, with the aim to help them to familiarize with it and to have
the opportunity to create immediately something reasonably “productive”. LibreCAD
has not yet a real completed manual, this task has taken in charge by a group of brave
men, but you can find some piece of advice into the forum; moreover, even LibreCAD has
been totally rebuilt, an idea of its use can be found on Qcad manual. Here I'm using the
version 2 of LibreCAD.
This tutorial is also for people that simply need a quick review about the program's
commands. In this little tutorial then, we are going to draw a little part in order to get
people more into LibreCAD. I suggest to people that have no idea about this program
works, to spend a little time playing with this nice program, I mean, the menus, the lists
(block list and library browser), the command line, the sub-menus, and so on. People
used to other cads will find easier to understand the icons' logic.
Finally I would like to thank Mr. Rallaz of the developers team, that gave me the drawing
we are going to replicate, in fact even if I can use this LibreCAD I'm not in mechanics, so I
needed something understandable realistic to draw... Thanks Rallaz then!
Now we can start our little journey in this drawing.
Have fun!
Claudio
CLAUDIO GUARNIERI: Drawing a little mechanical part using LibreCAD – Page 2 of 17
Getting started
Well, we have our program run and we are about to start.
First, before set the drawing, the layers and so on, this picture down here represents the
drawing that we are about to create, the final result:
First go to Edit >Current Drawing Preferences, then set the “paper” section to A4
landscape, then on “grid” section select “Orthogonal Grid”. We are not using “splines”
but about “units” and “dimensions” look the picture below:
CLAUDIO GUARNIERI: Drawing a little mechanical part using LibreCAD – Page 3 of 17
Well, now we can finally set the layers. In order to set layers you need to have the layer
list window active, if you do not see it just click the right mouse button a free space on
the top bar and click with the left mouse button near “layer list” and... Ta daa!!! We have
a layer list! Fine, when you have the list the highlited layer is the one you are working in,
and if you look down here you can see the relative menu, and precisely
Remember, the first thing to do, especially in big drawings, is setting the layers, it saves
time and sometimes keeps the work readable and understandable.
Personally I left to layer 0 its default settings and I gave to the layers the following
settings as resumed down here:
Layer name Color Thickness Line type
Sections Blue 0,5 Continuous
Dimensions Magenta 0,18 Continuous
Hatches Grey 0,13 Continuous
Borders Green 0,18 Continuous
Axes Red 0,25 Dash dot (small)
Down here the interface menu to set the layers, naturally each description is to set the
relative parameter:
And finally we have set the layers!!! Up to now it has not been too difficult, am I right?
CLAUDIO GUARNIERI: Drawing a little mechanical part using LibreCAD – Page 4 of 17
Hide all layers
Add a layer
Remove a layer
Layer proprieties
Show all layers
Show/hide relative layer
(in this case layer 0)
Lock/unlock the
near layer
Print or do not print
the layer objects
Snaps
I know I know, you want draw, but this is really important!!! Let me spend some words!
Snaps are particular points that you can use as start points to create an object, as
reference for dimensioning and so on, they are important because without them we
would entirely type coordinates and coordinates and coordinates and coordinates and
coordinates and coordinates, well you know... In this nice bar we have also horizontal and
vertical constraints and the zero positions. Now take a look down here, we have:
Look down here to have an idea about how much important snaps are, the same try with
the snap grid turned on at the left and turned off at the right!
Take familiarity with this bar, it will save much time and will save your er... neck many
times!
CLAUDIO GUARNIERI: Drawing a little mechanical part using LibreCAD – Page 5 of 17
Free
Snap on grid
Snap on endpoints,
notice that this little
contour means that
this snap is selected
Snap on entity
Snap center
Snap middle, this snap
can assign more than a
middle point to a line Snap distance
Snap
intersection
Horizontal
constraint
Vertical
constraint
Set relative
zero position
Lock relative
zero position
First lines
First something about coordinates:
Orthogonal coordinates: they are coordinates that are identified through an abscissa
and an ordinate.
Polar coordinates: they are identified through a distance and an angle.
Now, no matter if you use orthogonal or polar coordinates, if you simply insert
coordinates , they will be referred to the absolute zero (the red cross into the
workspace), if you type the @ simbol before the coordinates you will insert the
coordinates relatively to the red cursor (the little cirlcle with a cross inside it).
Ok friends, now it's time to draw. Each drawing can have a border or can have it not.
We are going to put it; the paper is an A4 and we wants 5 units of border, then our
border will be 287 x 200 units.
As you can see LibreCAD has a menu on the left, this will be our closest friend when we
are using this program.
Now, be sure to operate in layer 0, then click (left mouse button) on the icon “lines” and
on the sub-menu “rectangles”. On the command line we will read “Specify first rectangle
corner” and we'll type 0,0. Then to give the second corner we have to insert 287,200 and
our border will be set (Remember an A4 is 297 x 210 millimeters)!
Now we are going to draw the very part of this tutorial, as you can see it is a cross
section drawing, the section is cutting in two halves this part.
The order will be:
1. The orthogonal view;
2. The isometric view.
Part1:
We are going to draw first the sectioned part (the part filled with oblique lines). Now
be sure to operate on the layer SECTIONS, and we can start. Look at the picture: as you
can see there is a cylindrical hole having 25units as diameter and 7,5 height. The squared
part side is 45 units, then the difference on that area will be 10. The picture down here
gives the dimensions of the sectioned part if you keep reasoning in this way:
CLAUDIO GUARNIERI: Drawing a little mechanical part using LibreCAD – Page 6 of 17
Now, through the command “line” you can insert all the coordinates. Notice that in this
case there are command icons called horizontal line and vertical line. If you click on them
a dialogue will appear on Tool Options menu (if you do not see it right button click on a
free area on the bar and select Tool Option); here you can insert the length of the lines,
also the point of attachment, so it will be easier to create the shape in the previous
page. Look down here to have a better idea:
Now we have to create the border lines, look at the first picture on page 3, the distance
between the axes and the cylinders are 12,5 and 8 units. So we need to create lines like
down here (you should not have drawn the axes yet)
In order to draw the axes just switch to layer AXES and draw a line with two points,
selecting the A and B points, so the axes will be created from A to B; now we need to
extend it: click on Modify>Lengthen (actually this command is listed as “Trim by
amount”), enter a number on the command line, (keep 10 or 12 as reference of
extension), then click the axes near the top and near the bottom and the magic is done!
So far, your situation about the red dash-dotted axe should be exactly like the picture up
there. Now keep considering the picture above, this is the half of the entire picture, and
we have two methods to operate; the first method is switch to BORDERS layer and
drawing the entire left border considering it as a mirror of image at page 5 then join the
lines that need to be joined, the second method, more easy, time saving and cool is...
CLAUDIO GUARNIERI: Drawing a little mechanical part using LibreCAD – Page 7 of 17
A
B
D
C
E
F
...Modify>Mirror!!! So, the description of this second way is longer then the description
of the first one, but once you've learned it's really fast. So, switch to BORDERS layer and
select lines CD, DE and EF. Select Modify>Mirror and give confirm, when LibreCAD asks
the two points click on the top and the bottom points of the red axes, remember to keep
the original, and les jeux son faits! Now we are at this point, look down
Now, select the new lines from point 1 to point 4, click on Modify>Edit Entity Attribute
and give confirm; corresponding to the writing “layer” select BORDERS
And finally look here: we have the borders!
CLAUDIO GUARNIERI: Drawing a little mechanical part using LibreCAD – Page 8 of 17
1
2 3
4
Well, now it remains to join the lines, so use Modify>Extend by amount, or... Well, this is
the very method I always use to join lines, look down friends
Here I selected the segment 1-2 (image at page 8). If you look closely at the endpoints
there are two blue dots, they are important because if I click one of the two endpoints
and I keep the left mouse button clicked, the line becomes elastic and I can drag it
wherever I want, even to an endpoint snap! So that's the trick! Notice that if I select
more than entity at once I'll move one point, but two entities will be modified. Look
down here
Anyway once you'll have learned well, you'll find this feature really helpful as I did!
Now the next step is create a hatch on the cut area, so we need to switch to HATCHES
layer, then we have to select all the blue polygon of “section” layer, now click on Create
Hatch, give confirm and select on the dialog box the hatch “ansi31” scale 1 and angle 0.
Down here I modified the preview in order to avoid doubts, those lines are the hatch!
CLAUDIO GUARNIERI: Drawing a little mechanical part using LibreCAD – Page 9 of 17
The final step is give dimensions to our work. So just be sure to operate on DIMENSIONS
layer, then click on Dimensions> horizontal dimensions Dimensions> vertical dimensions
so using the snap bar to set the place to put them. Remember to add the diameter
symbol of the 25 and 16 units diameters into the following Tool Option bar
As you may have noticed, those two diameters are not yet like they appear in the
drawing at the beginning... Well, it's time to another little trick: first we are going to
select those two dimensions, then we have to click the icon Modify> Explode and give
confirm. Now there are separates entities and we can delete the ones that we don't
need! Simple isn't it? And the orthogonal art is done!!!!
Part2:
This part can seem more complex, but is simpler than it seems: in isometric drawings
there are angles that never change; I mean that we subdivide the space in angles of 120°.
Look the arrow in the picture, it indicates how the rotation works. If you still do not
understand I'll try to answer to your questions with the following image:
CLAUDIO GUARNIERI: Drawing a little mechanical part using LibreCAD – Page 10 of 17
Now I am quite sure that you have understood the meaning of that kind of clock and I am
also sure that you understood that we are going to use polar coordinates.
I intentionally avoided to skip talking about axes X, Y and Z so far, because LibreCAD is a
2D cad, then it would be forcing it to make its own something that does not belong to it,
for this reason I did not go far from the angles considerations.
Anyway to suppose a hypothetical 3 axes system we would find someting as following
So using polar coordinates means that X lines will have angles of 30° or 210°, Y lines will
have angles of 150° or 330°, and Z lines will have angles of 90° or 270°.
Well, let's go on then!!!
Keeping as reference the drawing on page 3, there we have all the dimensions we need
to proceed, we just have to keep in mind that strange clock at page 10.
Down here I put the lines' dimensions to give for the isometric part:
CLAUDIO GUARNIERI: Drawing a little mechanical part using LibreCAD – Page 11 of 17
Z
90° or 270°
X
30° or 210°
Y
150° or 330°
Remember the input way: click Lines> line with given angle, then insert in Tool Options
the numbers! Here in the picture there is an angle of 150 degrees, a length of 10 units
and the snap point selected is start, this means that in this case you will enter the line
from the start, but you can also choose to enter it from the end or from the middle.
The method is simple, remember that:
1. Z axes has always the number and 90° as angle;
2. X axes has the number and 30° or 210°,
depending on the snap insertion that you
choose, start or end;
3. Y axes has the number and 150° or 330°,
depending on the snap insertion that you
choose;
4. The command MIRROR, in this case is exploitable
at 100%, once you have done left or right the
other side will already be done, just six clicks!
Remember also to be sure of being in the proper layer, if you were not, is not necessary
to redraw everything, simply select the entities that need to change layer and go to
Modify> Edit Entity Attributes, then select the correct layer! Ok, if I am not mistaking
you should be in a similar situation, depending if you have done the hatch, if not, do it:
This is pretty unrealistic, isn't it? In fact we are going immediately to add the round
borders!
As everyone can assume, even if in the reality round parts are circles, we are obviously
going to draw ellipses. I have a particular method to draw them and remember that is
simpler than it seems!
CLAUDIO GUARNIERI: Drawing a little mechanical part using LibreCAD – Page 12 of 17
Our little project has a 45 units sided square at the top, so first of all, switch to a random
layer that is not BORDERS, because what we are about to draw will be deleted once we
will have created our ellipses. I am operating on layer 0 anyway.
Now, we have to consider that a circle is always inscribed in a square, and its diameter is
the half part of the square side, if I have not been clear enough just look down here
Our drawing has 5 circles that creates cylinders of the piece. Looking at the orthogonal
part (Part1) and starting from the top their diameters are:
• 25 units;
• 25 units (external circle);
• 16 units (internal circle);
• 16 units (internal circle);
• 40 units (external circle).
So we are going to draw five squares in the isometric view.
The first square is 25units sided, so let's create its axes on the isometric piece; those
axes will be useful for the other ellipses too! Anyway look here:
CLAUDIO GUARNIERI: Drawing a little mechanical part using LibreCAD – Page 13 of 17
Y axesX axes
I just turned off
HATCHES layer
I just turned off
HATCHES layer
Fine, now go in a free area, and create a 25units sided square in isometric view, just use
the polar coordinates and X-Y angles, then create a horizontal line from left to right
vertex. Here the result (naturally I have just put dimensions to show):
Next, using the command Modify>Move/Copy move this figure using as first point the
horizontal line middle point and as final point the intersection of the two axes that we
have drawn int the previous page. We can delete the horizontal line. The result is like the
picture below, except for the horizontal line that I left for a better understanding:
Now we have to create the foci! To do that we need to join the high vertex of the square
to the middle point of the opposite sides and join the low vertex of the square to the
middle point of the opposite sides, and here we are:
CLAUDIO GUARNIERI: Drawing a little mechanical part using LibreCAD – Page 14 of 17
E F
D
A
C B
H G
Finally we can switch to layer BORDERS, and it's time to create our ellipse through the
command... Arcs! Yep, you have read well! So click on Arcs> Arc with Center Points
Angles. Then select A as center, then select segment AC as radius, finally, D as start point
and C as final point and... voilà!!!Using the same w ay center in D, radius is DE, the start
point is E and final point is F! Eureka!!! We have create an ellipse! Look down here:
The next thing to do is delete the square and that we don't need anymore, delete also
“a” and “b” lines. Next create a 7,5 units vertical line from point Q towards the bottom,
7,5 units because this is the measure in the drawing, look the dimensions at page three!
This is the segment QK. Creating the second ellipse is really easy, just use the command
Modify>Move/Copy and give Q as first point and K as final point. Ta daaa!!!
Then, (I switched back to layer 0) create another square 16 units sided in a free space,
create axes and ellipse construction lines, then move it from its geometrical center to K.
Here the result:
CLAUDIO GUARNIERI: Drawing a little mechanical part using LibreCAD – Page 15 of 17
Q
K
Q
a b
I turned off AXES
layer to make more
readable this image
Now you should know what to do, switch to layer BORDERS and create the ellipse with
the appropriate centers and radiuses. Next create a vertical line of 45 units from K point
towards the bottom (dimension taken from drawing on page 3).
Finally select this last ellipse and using the command Modify>Move/Copy, copy it using K
as first point and L as endpoint.
Finally create a 40 sided
square, axes, diagonals and so on, move this figure from its center to L point and create
the last ellipse. Then delete QK and KL segments. The final picture will be this one.
Remaining in BORDERS layer, create vertical lines from points U and T towards the
square borders to complete the picture. Now you can delete the square!
And yo will have just to delete the ellipses parts that are exceeding. To to this go to
Modify>Divide and choose first the entities to be cut, then where to cut (use snaps!)
CLAUDIO GUARNIERI: Drawing a little mechanical part using LibreCAD – Page 16 of 17
Q
K
L
U T
And you will have drawn the entire part, orthogonal view and isometric view!!! That's all!
Conclusions
Well, I hope that you found this tutorial interesting, I am pretty sure that you may have
found too long some parts and too short some others, I hope anyway that you have
taken more familiarity with this useful program. There are a lot of features that here
have not been even considered, but just be curious, that's the secret! I would like to
thank carbonardo and LordOfBikes of the forum about the Lengthen command, that was
not explained properly in the previous version of this PDF. I thank you too for reading
and...
See ya!
Claudio
CLAUDIO GUARNIERI: Drawing a little mechanical part using LibreCAD – Page 17 of 17

Online Document Converter

This website help webmasters to achieve a better user experience. Instead of putting a link to download their prices lists and another type of documents, you can simply send a special link to this service, and we will show your document to your users directly without the need of downloading a special application or installing another browsers plugin. Currently, we can read about hundred the most used database files. Moreover, your users can share this document directly on social networks, giving your document additional page views. By using this service, you can save costs by not overloading your own web server, give your users a better way to read documents online without any problems, and allow them to easily download converted copy for offline reading in a format they like.


Previous 10

Next 10